Issues with Login

Incident Report for BitLaunch

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 20:34 UTC

Monitoring

Logins are currently working as expected. We will continue to monitor.
Posted Jun 12, 2025 - 20:30 UTC

Identified

The issue is related to the current widespread Cloudflare outage.

Please let the support team know if you require any urgent assistance with your account and we can help.
Posted Jun 12, 2025 - 19:37 UTC

Investigating

We are currently experiencing issues with our login system. We're actively investigating this issue.
Posted Jun 12, 2025 - 19:03 UTC
This incident affected: Web App.