BitLaunch LAX outage

Incident Report for BitLaunch

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 10:38 UTC

Monitoring

The issue was with a circuit breaker which has now been replaced. Services should be back to normal.
Posted Jul 22, 2025 - 23:52 UTC

Identified

The issue appears to be with a failed PDU which is being replaced now.
Posted Jul 22, 2025 - 23:31 UTC

Investigating

We are currently investigating a network outage in LAX. We'll provide any updates here.
Posted Jul 22, 2025 - 22:38 UTC
This incident affected: BL Networks (LAX1).