Outage in our Los Angeles region

Incident Report for BitLaunch

Resolved

The issue was caused by a problem with our upstream's iBGP session. Their network team has identified the root cause and successfully resolved it.
Posted Jun 25, 2025 - 09:08 UTC

Monitoring

Connection has been restored and we're looking into the cause of the issue with our upstream
Posted Jun 25, 2025 - 08:40 UTC

Update

We have contacted our upstream to receive information on the nature of the outage
Posted Jun 25, 2025 - 08:06 UTC

Investigating

We are currently investigating this issue.
Posted Jun 25, 2025 - 07:54 UTC
This incident affected: BL Networks (LAX1).