Small Delay Processing Payments

Incident Report for BitLaunch

Resolved

This incident has been resolved.
Posted Jul 04, 2025 - 12:27 UTC

Identified

We have identified an issue with our payment system which will result in a small delay before transactions are credited. We expect this to be resolved sometime soon.
Posted Jul 04, 2025 - 07:36 UTC
This incident affected: Payments.