Ethereum payments temporarily disabled
Incident Report for BitLaunch
Resolved
Ethereum payments have been re-enabled
Posted Aug 15, 2024 - 07:12 UTC
Identified
We are currently investigating an issue with Ethereum payments.
Posted Aug 14, 2024 - 12:15 UTC
This incident affected: Payments.