Outage in Los Angeles

Incident Report for BitLaunch

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 14:00 UTC

Monitoring

Power has been restored and we are powering back up user servers
Posted Jul 22, 2026 - 13:04 UTC

Update

We are awaiting news from an on-site inspection. We apologize for the length of this outage.
Posted Jul 22, 2026 - 12:03 UTC

Update

An on-site technician has been assigned to this and an in-person investigation is taking place.
Posted Jul 22, 2026 - 09:54 UTC

Update

We're in contact with our upstream provider to find out what the issue is specifically and how long it might take to fix.
Posted Jul 22, 2026 - 08:58 UTC

Investigating

We are currently investigating this issue.
Posted Jul 22, 2026 - 02:00 UTC
This incident affected: BL Networks (LAX1).