Hardware issue with a node in Amsterdam
Incident Report for BitLaunch
Resolved
This incident has been resolved.
Posted Oct 25, 2023 - 19:30 UTC
Investigating
A hardware issue has occurred on a node in our Amsterdam Region. We're currently performing physical inspections on this hardware and determining the severity of the issue.

If you're having trouble reaching your server, please reach out to us on support.
Posted Oct 25, 2023 - 05:42 UTC
This incident affected: BL Networks (AMS2).