London networking outage

Incident Report for BitLaunch

Resolved

This incident has been resolved.
Posted Nov 15, 2022 - 01:29 UTC

Monitoring

Services are operational. We are actively monitoring.
Posted Nov 14, 2022 - 23:20 UTC

Identified

We have confirmed that the issue was at our upstream provider. We have requested a RFO.
Posted Nov 14, 2022 - 23:19 UTC

Update

London is partially back. We believe this to be an issue with our upstream. Our engineers are working with them to identify and resolve the issue.
Posted Nov 14, 2022 - 22:57 UTC

Investigating

We are currently investigating this issue.
Posted Nov 14, 2022 - 22:32 UTC
This incident affected: BL Networks (LON1).