Outage in London
Incident Report for BitLaunch
Resolved
We are moving the status of this event to maintenance until the original network is restored. Connectivity will continue to run on a backup network.
Posted Apr 23, 2022 - 16:00 UTC
Monitoring
We have migrated to the new network inside the datacenter and servers are coming back online. We want to thank those affected for their patience and understanding while we worked to get back online.
Posted Apr 22, 2022 - 23:44 UTC
Update
The datacenter are still working on the fiber repair but as an alternative course of action, a new network is being built. We expect to migrate to this new network shortly. We are all-hands on this until it is resolved. Our sincere apologies and thanks for your patience once again.
Posted Apr 22, 2022 - 19:54 UTC
Update
Work is still in progress on the repair.
Posted Apr 22, 2022 - 18:01 UTC
Update
We apologise for this incident and inconvenience caused. The upstream network engineers are working around the clock to get this issue solved but right now we are unable to share an ETA.
Posted Apr 22, 2022 - 15:56 UTC
Update
Work is still underway from our upstream to restore networking to our London location.
Posted Apr 22, 2022 - 15:37 UTC
Update
Unfortunately this appears to be taking longer than expected. We will continue to post updates from our upstream as we get them as the repair is underway.
Posted Apr 22, 2022 - 11:02 UTC
Identified
Unfortunately there is a fiber cut between the routing facility and hub. A repair is underway and we're hoping for a resolution within the next few hours.

Moving forward, a further fiber ring will be built for redundancy.
Posted Apr 22, 2022 - 07:11 UTC
Update
Our DC engineers are continuing to investigate this issue.
Posted Apr 22, 2022 - 00:34 UTC
Update
This incident is being worked on by DC engineers. We will follow up with updates.
Posted Apr 21, 2022 - 22:28 UTC
Investigating
We are currently investigating this issue.
Posted Apr 21, 2022 - 21:28 UTC
This incident affected: BL Networks (LON1).