London Outage

Incident Report for BitLaunch

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 13:48 UTC

Monitoring

Service has been restored. However, our upstream network team is currently checking in with their own upstream, as their handoff link experienced a disruption.
Posted Apr 29, 2026 - 13:15 UTC

Investigating

There is currently an outage in our London location. We have contacted our upstream to investigate this issue.
Posted Apr 29, 2026 - 12:42 UTC
This incident affected: BL Networks (LON1).