Maintenance in London
Incident Report for BitLaunch
Resolved
This incident has been resolved.
Posted Apr 18, 2024 - 14:55 UTC
Monitoring
Maintenance is still on-going so further services may be impacted.
Posted Apr 18, 2024 - 12:33 UTC
Identified
A DC engineer is performing maintenance on fibre and cables at the DC. We expect this to be brief.
Posted Apr 18, 2024 - 12:06 UTC
Investigating
We are currently investigating this issue.
Posted Apr 18, 2024 - 11:49 UTC
This incident affected: BL Networks (LON1).