We have contacted all users affected by this hardware issue. Please reach out to our support if you have any questions.
Posted Jan 21, 2025 - 12:15 UTC
Identified
Unfortunatetly despite best efforts of technicians, it looks as though this physical host is not able to be recovered. We will be contacting affected users shortly.
Posted Jan 21, 2025 - 11:44 UTC
Investigating
We are working with datacenter technicians to diagnose an issue with a physical host in our London region. Some user servers will be affected.