Outage in Dallas
Incident Report for BitLaunch
Resolved
This incident has been resolved.
Posted May 26, 2024 - 16:47 UTC
Monitoring
Power has been restored and servers are back online.
Posted May 26, 2024 - 14:59 UTC
Identified
A severe storm has impacted the Dallas area, causing a significant disruption in the power supply to the data center. This incident led to the complete loss of data center operations. Engineers are working with the local data center to get everything back online.
Posted May 26, 2024 - 12:31 UTC
Investigating
We are currently investigating this issue.
Posted May 26, 2024 - 11:41 UTC
This incident affected: BL Networks (DAL1).