Outage in Amsterdam 1
Incident Report for BitLaunch
Resolved
This incident has been resolved.
Posted Apr 20, 2022 - 09:59 UTC
Monitoring
Maintenance has been completed and we are monitoring the results. Services will begin coming back online.
Posted Apr 20, 2022 - 02:03 UTC
Update
Maintenance is still underway.
Posted Apr 19, 2022 - 23:55 UTC
Update
Maintenance is taking longer than expected as the datacenter works to replace power equipment.
Posted Apr 19, 2022 - 22:04 UTC
Update
Maintenance is still underway at the datacenter
Posted Apr 19, 2022 - 21:11 UTC
Identified
The datacenter where our hardware resides is currently performing unscheduled and unexpected maintenance due to equipment needing immediate care. There may be cases where your VPS will be restarted. We will update this page as we receive updates.
Posted Apr 19, 2022 - 20:53 UTC
Update
We are in contact with our upstream provider to find out the cause of the outage.
Posted Apr 19, 2022 - 20:25 UTC
Investigating
We are currently investigating this issue.
Posted Apr 19, 2022 - 20:21 UTC
This incident affected: BL Networks (AMS1).