AMS Outage (multiple regions)

Incident Report for BitLaunch

Resolved

This issue is resolved. Thank you for your patience and apologies for the inconvenience.
Posted Jan 08, 2024 - 01:36 UTC

Update

This was caused by an upstream routing issue.
Posted Jan 08, 2024 - 01:35 UTC

Identified

The issue appears to be with our upstream provider. Their engineers are working to resolve the problem.
Posted Jan 08, 2024 - 00:55 UTC

Update

This appears to be a partial outage. We are investigating the cause.
Posted Jan 08, 2024 - 00:17 UTC

Investigating

We are currently investigating this issue.
Posted Jan 08, 2024 - 00:06 UTC
This incident affected: BL Networks (AMS1, AMS2).