Outage in Los Angeles

Incident Report for BitLaunch

Resolved

Connectivity has been restored. We're working to improve stability in this region.
Posted Jul 26, 2026 - 17:47 UTC

Update

A host in Chicago was facing a memory issue. This host has been rebooted and a memory replacement scheduled.

Los Angeles continues to be investigated.
Posted Jul 26, 2026 - 12:20 UTC

Investigating

We are currently investigating reports of outages in these regions
Posted Jul 26, 2026 - 12:11 UTC
This incident affected: BL Networks (LAX1, CHI1).