ETH Payments Disabled
Incident Report for BitLaunch
Resolved
This incident has been resolved.
Posted Mar 29, 2024 - 13:09 UTC
Monitoring
ETH payments will be reinstated shortly
Posted Mar 29, 2024 - 09:06 UTC
Identified
ETH payments are currently disabled until we receive the latest chain information.
Posted Mar 28, 2024 - 09:26 UTC
This incident affected: Payments.