Outage in London
Incident Report for BitLaunch
Resolved
This incident has been resolved.
Posted Jul 22, 2023 - 06:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2023 - 20:27 UTC
Update
Our upstream networking team is actively addressing the problem, and we will provide updates as soon as we receive any information from them.
Posted Jul 21, 2023 - 18:36 UTC
Investigating
We are experiencing intermittent connectivity issues. We are currently investigating the issue.
Posted Jul 21, 2023 - 16:30 UTC
This incident affected: BL Networks (LON1).