Outage in Amsterdam
Incident Report for BitLaunch
Resolved
Amsterdam is back online with a small amount of VPS still impacted. We are continuing work on this.
Posted May 09, 2023 - 07:16 UTC
Update
Networks in our Amsterdam 2 region are back online. Amsterdam 1 work remains ongoing.
Posted May 08, 2023 - 22:30 UTC
Identified
We would like to inform you that emergency power maintenance is currently being performed.

Unfortunately, this maintenance was rescheduled at the last moment.

Please be advised that your services may be affected for several hours.

We sincerely apologize for any inconvenience this may cause, and we appreciate your patience and understanding during this time.
Posted May 08, 2023 - 21:18 UTC
Update
We are continuing to investigate this issue.
Posted May 08, 2023 - 20:44 UTC
Investigating
We are currently investigating this issue.
Posted May 08, 2023 - 20:29 UTC
This incident affected: BL Networks (AMS1, AMS2).