Outage in London Region
Incident Report for BitLaunch
Resolved
This incident has been resolved.
Posted Jan 30, 2024 - 16:51 UTC
Monitoring
Connectivity should be restored. The issue appears to be related to an outage with an upstream provider. We are continuing to monitor network connectivity.
Posted Jan 30, 2024 - 13:59 UTC
Investigating
We are currently investigating this issue.
Posted Jan 30, 2024 - 13:26 UTC
This incident affected: BL Networks (LON1).