Amsterdam Outage
Incident Report for BitLaunch
Resolved
This incident has been resolved.
Posted May 04, 2024 - 08:44 UTC
Monitoring
Connectivity is restored, we are continuing to monitor for any additional issues
Posted May 03, 2024 - 23:38 UTC
Identified
Our upstream's DC team is working diligently to solve the issue and we will provide updates as soon as possible
Posted May 03, 2024 - 23:28 UTC
Investigating
We are currently investigating this issue.
Posted May 03, 2024 - 22:11 UTC
This incident affected: BL Networks (AMS2).