Further maintenance in the London region
Incident Report for BitLaunch
Resolved
Network connectivity is currently restored. We will remain in touch with the datacenter to determine if further maintenance tasks are necessary.
Posted Dec 08, 2021 - 16:09 UTC
Identified
Further maintenance is being performed in the London region by the datacenter.
Posted Dec 08, 2021 - 15:30 UTC
This incident affected: BL Networks (LON1).